USMT : In-place Refresh with Upgrade from Office 2007 to Office 2013 Breaks Enterprise Vault

Took a while to resolve this one, with the help of Microsoft PSS.

The Problem

The refresh involves using the User State Migration Tool version 5 to capture user settings/preferences and data from old devices and restore to new machines once the Operating System and applications such as Office are deployed.

Source/old machines are running Windows Vista or Windows 7, Office 2007 and have the Enterprise Vault Add-In for Outlook version 9.0.2.1136. Target/new machines have Windows 7 SP1, Office 2013 and Enterprise Vault Add-In for Outlook version 10.0.3.1090. All operating systems are 32-bit. On machines where the User State Migration Tool is used every time Outlook is opened the following error is presented:

Either there is no default mail client or the current mail client cannot fulfill the messaging request.

If Outlook is started using outlook.exe /safe it opens without issue. If I disable the Enterprise Vault Add-In within Outlook, it opens without issue.

The Fix

Modification of the following reg key will resolve the issue without an Office repair:

HKLM\SOFTWARE\Clients\Mail\Microsoft Outlook\MSIComponentID

Set this to the following value to resolve the issue: {6DB1921F-8B40-4406-A18B-E906DBEEF0C9}

Initial tests excluding this from capture/restore via a custom XML but this doesn’t seem to workw so we’re now using the following Run Command Line step in the USMT Task Sequence to resolve the issue:

reg add “HKLM\SOFTWARE\Clients\Mail\Microsoft Outlook” /v MSIComponentID /t REG_SZ /d {6DB1921F-8B40-4406-A18B-E906DBEEF0C9} /f